Ubuntu 12.04 Solución al ruido sonido repetitivo de los parlantes bocinas tarjeta de sonido en bateria

Saludos lector.

Hay un problema con Ubuntu 12.04 con los portátiles ( laptop ) en el modo de ahorro de energía que ocasiona un sonido repetitivo desde la tarjeta de sonido, este sonido lo podría representar (en mi caso) con “pop”.

De lo que leí para dar solución al problema es que Ubuntu apaga y enciende cada tanto tiempo la tarjeta de sonido para así en esos intervalos ahorrar energía. El detalle es que puede ocasionar un sonido preocupante, entonces veremos la solución.

Primero que todo, apenas detectes el sonido repetitivo en tu laptop abre la terminal (consola) y logueate como root con

sudo su

a continuación, pega la siguiente instrucción y da enter:

sudo echo 0 > /sys/module/snd_hda_intel/parameters/power_save

Esto debería hacer que, luego de un último sonido de pop despues de introducir la instrucción anterior en la consola, este desaparezca.

Hasta ahora todo perfecto, pero al reiniciar el portatil tendrías que volver a digitar la instrucción en la terminal para que no aparezca el sonido, entonces vamos a hacer esto permanente.

Logueandose como root (sudo su) en la consola, pasamos a escribir lo siguiente:

gedit /etc/rc.local

lo que abrirá en el editor de textos gedit el archivo rc.local

ahora, antes de la última línea que dice “exit 0” escribimos la línea:

echo 0 > /sys/module/snd_hda_intel/parameters/power_save

guardamos el archivo y listo, ahora en cada reinicio evitaremos el problemita aquel con el sonido repetitivo.

He de apuntar un detalle importante, si has instalado algún programa para gestión de la energía, por ejemplo Jupiter, esto te va a jugar muchas malas bromas con respecto a solucionar el problema del ruido este… me pasó a mi y me volvió loco por un buen rato. Lo que pasa es que los programas de gestión de energía, o por lo menos júpiter, cuando desconectas el cargador del portatil vuelve a cambiar el valor del archivo /sys/module/snd_hda_intel/parameters/power_save a 1 (uno) haciendo que el problema vuelva a presentarse. Entonces, si te pasa algo raro con la solución ya puedes tener algo de idea de que sucede.

Bueno, un saludo.

solución al problema en lenovo ideapad y460p de ruido y sonido estridente en bocinas con bloqueo

Hola lector, tal vez también tengas la mala fortuna de tener un lenovo ideapad y460p y haberte dado cuenta que de forma esporádica mientras reproduces música u otro sonido tus parlantes o bocinas del portatil producen un sonido, un ruido extridente, fuerte que podría imitarlo con el sonido ÑEEEEE . En esos momentos lo que sucede viene acompañado de un bloqueo completo del computador para luego seguir como si no pasara nada.

Bueno, el día de ayer si mal no estoy se venció mi garantía y mi último intento de solución con lenovo fue, al atenderme por la línea de soporte técnico, el cambio del disco duro… pero no funcionó.

Bueno, primero diré la solución, luego daré los detalles del caso… cualquier duda  agradezco me dejen un comentario al final de esta publicación

La solución al problema es desistalar todos, si, TODOS los drivers del portatil, dejarlo sin ninguno de los drivers, en especial el de lenovo energy management. Luego proceder a instalar solo los drivers que corresponden a:

– Audio
– Touchpad
– Video
– bluetooth
– Ethernet
– Wireless (no buscar en lenovo, instalarlo desde windows update)
 
(estos descargados desde http://support.lenovo.com/en_US/downloads/default.page? e indicando que el modelo es y460p )
 
Como inicialmente no tienen ni un solo driver, el procedimiento que yo seguí fue primero bajar los drivers desde otro equipo, luego instalar el de Ethernet descargado para poder conectar a internet el portatil via cable, luego con la ayuda de windows update seleccionar el driver de la tarjeta inalámbrica (wireless o wifi). Instalo de esta forma el driver de Wireless porque en la página de lenovo hay muchos drivers diferentes para y460p, entonces prefiero que windows determine el correcto. Y luego a partir de los instaladores de los otros controladores instalarlos uno por uno.
 
De los resultados colaterales a observar es que los botones de la parte superior del teclado, como lo son los atajos para subir-bajar-quitar sonido y todos dejan de funcionar… pero ante eso con el boton FN de la parte inferior izquierda del teclado y los de flecha izquierda y derecha se puede subir-bajar el volumen. También ya no podremos utilizar el programa de gestión de la energía de lenovo, que permite tenerlo en modo de alargar la vida de la batería… ahora se tendrá que utilizar los modos de ahorro de energía que ofrece windows (así como cualquier otro portatil HP, dell, etc)
 
A pesar de los efectos secundarios no deseados podrán ver que los bloqueos y los ruidos estridentes desaparecen en gran medida… podrían esperar que sucedan a lo mucho 1 o dos veces por semana… o incluso ni una vez por semana (ya no pasará varias veces al día)… pero ante esto tengo que decirles que en otro portatil de la marca dell con procesador intel i5 también se presentan estos bloqueos cada tanto (por ahí 1 vez por semana) así que con los pasos que les indico se puede dejar funcionando el portatil como si fuera de la marca dell (con respecto al ruido y bloqueo)
 
¿de donde saco esta solución tan “descabellada”? de mi propia experiencia, de ver que no hay otra solución posible. los detalles de porqué digo esto es mi experiencia resumida en el correo que le escribí a lenovo que adjunto a continuación:::
 
DETALLES
 
En mi portatil lenovo ideapad modelo 460p con referencia S/N QB03434177 desde su compra el 27 de agosto de 2011 ha presentado un problema de bloqueo, que al estar reproduciendo sonido produce un ruido extridente.
 
La forma que detecté este problema inicialmente fue gracias a tener el equipo reproduciendo música constantemente y notar que exporádicamente se producía un sonido desagradable que podría representar con el sonido “ÑEEEEEEEEEEEEEE” por un lapso de aproximadamente 1 segundo, esto una o varias veces por sesión de trabajo en mi equipo.
 
Cuando sucede esto, todo el equipo se bloquea, incluso el movimiento del puntero sobre la pantalla se detiene, se bloquéa también. Posteriormente cuando termina este suceso el equipo continúa normalmente como si nada hubiera sucedido.
 
Luego de cada instalación como venía de fábrica que he hecho, de también instalar los programas que uso normalmente y de un tiempo aproximado de 1 mes el problema parece asentuarse, ya los bloqueos son mas seguidos por día de trabajo. Esto genera preocupación, algunas veces se me presentaban estos bloqueos de forma repetida cada minuto y así parece ser que algo va muy mal en el portatil. Por este motivo he tenido que reinstalar el sistema como venía de fábrica con el recovery repetidas veces para que se disminuya un poco el problema pero este se sigue presentando. Ya estoy cansado de verme obligado a reinstalar el sistema completo, de actualizarlo, de instalar mi sistema casi casa mes. 
 
Por cierto, me sucedió también hace muchos meses que el equipo se bloqueaba completamente y se quedaba produciendo el sonido extridente ÑEEEEEEEE!!! sin detenerse lo cual me obligó a apagarlo de manera forzosa extrayendo la batería. esto sucedió como 2 veces y de vuelta tuve que formatear el equipo.
 
He de apuntar que he estado buscando solución en el foro de lenovo en español, yo publiqué el tema
el 25 de abril de este año buscando orientación. No recibí respuesta públicamente, pero si de forma privada de un usuario con nombre de usuario anghelomend que tiene el mismo modelo de equipo y ha tenido la misma falla. De forma esperanzada hemos probado un par de soluciones que el usuario anghelomend ha encontrado en el foro de usuarios de lenovo en idioma inglés como lo ha sido la instalación de driver de la bios:
– 3fcn22ww_64.exe del 07 de junio de 2012
que supuestamente solucionaba este problema pero no funcionó en últimas, el bloqueo exporádico sigue presentandose. 
 
Lo verdaderamente molesto es que generalmente se presenta el problema de forma exporádica, aunque también se puede reproducir la falla conectando y desconectando el cargador al toma de energía, y cambiando rapidamente entre los modos de energía que ofrece el sistema, de “alto rendimiento” a “equilibrado” a “economizador” “energy star” mientras se mueve el puntero del mouse (o touchpad en este caso) .El bloqueo que se presenta al hacer esta prueba es de las mismas características al que se produce exporadicamente.
 
Como al hacer estas pruebas se puede creer que el problema está con el control de energía de la batería yo hice la prueba de desistalar el software de control de batería de lenovo y dejarlo funcionando solo con los que proporciona windows 7. El bloqueo al conectar y desconectar el cargador de la batería y al cambiar los modos de energía de batería desaparece _PERO_ el problema en forma exporádica sigue ocurriendo.
 
Como el problema siguió presentandose exporádicamente, decidí intentar instalando el sistema desde cero con un instalador de windows 7 de prueba por 30 días logrando que el sistema viniera limpio de controladores. Así lo hice, y para poder utilizar el sistema de forma mas o menos cómoda decidí instalar unos cuantos controladores:
– Audio
– Touchpad
– Video
– bluetooth
– Ethernet
– Wireless
( estos se descargaron desde la página
introduciendo el modelo del equipo y460p
)
Solo los anteriores y dejando el resto con los controladores que proporcionaba windows.
Parecía estar funcionando bien por mas de 1 semana, pero luego, otra vez se presentó el bloqueo y el ruido extridente. Por cierto, luego de ver que el problema persistía instalé el resto de controladores para mi modelo de equipo descargados de la misma página pero igual, el sistema siguió fallando.
 
Otro prueba que realicé gracias a la información que me proporcionó el usuario anghelomend fue utilizando el programa DPC Latency Checker para observar este índice. Utilizando este software se observa que cada tanto hay valores altos de latencia, incluso de 16000us que no se perciben como un bloqueo. Realicé esta prueba en otros dos portatiles de otras marcas y sucedía de igual manera _EXCEPTO_ cuando se detecta el bloqueo con el ruido extridente cuando se escucha sonido.
 
Cuando tenía el programa DPC Latency Checker activo y se presentó el bloqueo exporádico que detecté con el sonido extridente “ÑÑÑEEEEEEEEEEE” el programa mostraba que había ocurrido una medida de latencia de 108865 us. Estos niveles de latencia también se logran al probar con los controladores de gestión de energía de lenovo instalados y probando conectando y desconectando el cargador además de cambiar rápidamente los planes de energía dando valores de 125591 us y 105392 us en dos de las pruebas… y por supuesto, también sonó el ruido extridente.
 
Algo que leí sobre la latencia DPC es que esta está ocasionada por los drivers instalados, al menos parece tener sentido con los drivers de gestión de energía de lenovo que generan el problema de altos niveles de latencia y el bloqueo y ruido extridente al conectar y desconectar el cargador y cambiar los planes de energía _PERO_ igual al probar el sistema con pocos drivers el problema se sigue presentando exporádicamente.
 
En todo este tiempo lo mejor que pude hacer para disminuir el problema fue instalando el windows 7 de prueba de 30 días instalando solo los drivers para
– Audio
– Touchpad
– Video
– bluetooth
– Ethernet
– Wireless
El problema pareciera haber desaparecido, pero como escribí mas arriba, luego de mas o menos una semana de utilizar el portatil (claro está, en sesiones de trabajo diarias donde cada día lo apago totalmente, _NO_ lo dejo funcionando encendido por mas de 1 día claro está) otra vez se detecta el problema, se escucha el sonido extridente cuando se está reproduciendo música y el programa DPC Latency Checker muestra valores altisimos en sus medidas.

Ubuntu 12.04 Problemas de instalación y primera impresión

Bueno, he instalado ubuntu 12.04 en mi equipo luego de varios intentos fallidos.

La experiencia con ubuntu 12.04 comenzó al intentar instalarlo en un portatil con bajos recursos y con tarjeta nvidia. Al tratar de configurar la tarjeta gráfica con el asistente para controladores propietarios se presentó un problema y no se pudo llevar a cabo el proceso… acto seguido bajé linux mint 13 y lo instalé en aquel pc.

Hace unas semanas volví a darle una oportunidad a Ubuntu en mi portatil, instalandolo de forma normal estando conectado a internet por la tarjeta inalámbrica (wifi) de mi portatil y esto demoró toda una tarde… se me hizo extraño pero no le presté mucha atención. Luego teniendo instalado Ubuntu 12.04 me dispuse a configurar la tarjeta gráfica, en este caso ATI Radeon HD6550M y de nuevo por el asistente falló.

Internet Inalámbrico Lento

El gran inconveniente que encontré en Ubuntu 12.04 al instalarlo fue que el internet iba lento, muy lento, algo que de entrada me parece inexplicable, inaceptable. Busqué en internet por la forma de solucionar esto y en últimas pareciera que no hubiera una solución única para todos… dependiendo de la marca de la tarjeta inalámbrica, ya sea atheros u otra aparecen varias opciones para solucionar el problema… y esto llega a ser muy confuso… incluso echa a perder la instalación porque los usuarios que somos novatos seguimos instrucciones de configuración que no estamos seguros de que daño conllevan.

Al final encontré la solución al internet inalámbrico lento como indico en el post https://samz550a.wordpress.com/2012/08/17/ubuntu-12-04-wifi-lento-solucion/

para mi portatil que tiene una tarjeta inalámbrica atheros… la instrucción que soluciona el problema dice:

nohwcrypt=1

Uhm… no manejo el idioma inglés… pero podría pensar que la instrucción dice que NO HARDWARE CRIPTA-ENCRIPTAR no encriptar por hardware… tal vez desactiva una encriptación que en ubuntu se configura por defecto.

Igual Ubuntu no tiene escusa, ese problema no debería suceder, incluso podría pensar que le ha quitado muchos usuarios, en su mayoría novatos que chocaron con este error. En mi caso, por ese problema instalé como 3 veces Ubuntu en mi equipo, y afortunadamente a la 3 la vencida di con la solución al problema en mi caso.

Tarjeta Gráfica ATI
continuara…

ubuntu 12.04 wifi lento solución

Luego de buscar y buscar en google, primero en español y luego (cuando agoté mis esperanzas) en inglés encontré la página:::

http://www.unixmen.com/resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal/

donde da 3 opciones para solucionar el problema de internet inalámbrico lento… en mi caso se solucionó con la primera opción que menciona “ath9k” … que es la misma palabra que encuentro al dar click en la barra superior en el ícono de la red inalámbrica,  opción “información de la conexión”…, ahí dice que ath9k es mi controlador.

Y bueno, he estado descargando un par de paquetes y he visto en el programa “monitor del sistema” que efectivamente al descargar se aprovecha toda mi conexión… igualmente al navegar todo va a la velocidad correcta.

Bueno, deseo que esta información le sea de utilidad a alguien… y recuerden, si la primera opción no les funciona, prueben la 2 y luego la 3… en el penoso caso de que no les funcione lean los comentarios de esta página que allí dan mas ayudas que han encontrado otras personas… es cierto, está en inglés pero con ayuda del traductor de google seguramente no se les dificultará mucho.

Un saludo.

Instalar drivers ati radeon en fedora 17

Estuve buscando en google sobre la instalación de los drivers para mi tarjeta gráfica ati radeon HD 6550M que viene en mi equipo lenovo y460p y leí que habían problemas con la instalación pero afortunadamente al parecer ya es cosa del pasado, a mi me está funcionando completamente bien, los acabo de instalar, reinicié y aquí estoy escribiendoles esto.

Antes de instalarlos con lo pasos que daré a continuación recomiendo seguir los pasos que indico en

https://samz550a.wordpress.com/2012/08/14/fedora-17-que-hacer-despues-de-instalar/

para que la descarga desde los repositorios sea rápida (hay que instalar los plugins para yum)

Y bueno, basandome en la página

http://us.battle.net/d3/es/forum/topic/6079708745

se instala por consola los repositorios rpmfusion

yum localinstall –nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

luego se escribe

yum check

yum update

y luego se instala los drivers así::

yum -y install akmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs

Luego se reinicia fedora 17 y listo, todo anda funcionando bien.

Deseo les sea de utilidad este tema, si es así o cualquier duda recibo comentarios.

Un saludo.

Fedora 17 que hacer después de instalar

Soy nuevo en fedora, y luego de instalarlo, busqué que hacer a continuación encontrando la página:::

http://www.evafedoramx.org/2012/05/29/que-hacer-despues-de-instalar-fedora-17

Donde sugieren primero actualizar por consola PERO seguramente te va a tomar mucho tiempo.

En mi caso por seguir paso por paso no vi que luego en el punto 3 comentaban que se podía mejorar yum instalandole unos plugins, pero aún así en mi experiencia va lento.

Busqué y busque en google con temas como:

yum lento, fedora 17 actualiza lento, cambiar repositorios, instalación de repositorios fedora 17 lento

y no vi la luz hasta que encontré que, además de instalar el plugin de yum

yum -y install yum-plugin-fastestmirror

que se supone que hace mejorar la velocidad de descarga exite también el plugin

yum-fast-downloader

que de verdad acelera la descarga, en serio, me descargó todo lo que necesitaba de forma rapidísima.

Para instrucciones sobre como instalar este último plugin les dejo el enlace

http://fedorigen.wordpress.com/2012/02/26/instalar-yum-fast-downloader-en-fedora-16/

en mi caso al seguir los pasos me decía que no estaba instalado el programa wget, para solucionar ese problema hice:

yum install wget

y listo, se instaló el programa y luego pude seguir los pasos.

Deseo a alguien le resulte util esta entrada al blog. Agradezco comentarios. Un saludo

Presentación

Hola, soy samzqca (samz550a), siendo este mi sobrenombre en internet cuando realizo consultas de temas de programación en java principalmente y sobre linux.

Con otros nicks he creado otra cantidad de blogs que he abandonado, tal vez porque en los otros había una relación directa con mi identidad real… espero no abandonar este, ya que ya tengo un objetivo con el… publicar las soluciones a problemas que se me presentan y que yo mismo me respondo o les encuentro solución.

Jejeje, me acordé de esta caricatura hecha por http://xkcd.com

Y pues si yo fuera DENVERCODER9 le podría ayudar dirigiendolo a mi blog 😀

Bueno, ya quiero publicar algo, hasta aquí dejo esta presentación